DevHints

Web Developer on Firefox 3.* (incl. Minefield)

Posted on: December 1, 2007

Okay so having never bothered playing with Mozilla Add-Ons, I was a bit frustrated with the lagging behind from Chris Pederick, author of the Web Developer extension. All that is needed is an update to the compatibility maximum version in the install file and it would work with Firefox 3, but alas, it hasn’t been updated.

Well, I did a little bit of tinkering and figured out how to get it all working.  For all you non-techies, I’ve made the xpi available so you can use it for your Firefox 3.* nice an easily. Right click an Save As the file linked below, then use Firefox to open it (File > Open) and continue on as usual.

Right Click and Save Me!

Advertisements

5 Responses to "Web Developer on Firefox 3.* (incl. Minefield)"

Thanks for sharing!
(You forgot to put http:// in front of download link.)

hi – this quickened my heart for a moment.. FF3b2 is a truley great leap forward, 2 had become unusable, but 3 absolutely needs WD ext. Unfortunately I couldn’t get your modded version to work. i got:

Firefox could not install the file at
file:///Users/tim/Documents/My%20Downloads/WebDev_3.xpi
because: Not a valid install package
-207

[OS 10.4.11, ppc, firefox 3.0 b2]

any ideas?

Awesome.

One problem. You can close the sidebar which opens when you Edit, or View Style information. The close button doesn’t work, and you’re stuck with that annoying sidebar…

Any idea how to fix that?

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: